天下网吧 >> 网吧方案 >> 方案实例 >> 正文

构建新一代-QOS设计与配置(4)


  五、WAN Qos配置与远程办公室Qos配置
  
    在路由器上使用模块化QOS命令行(MQC,12.2T),配置分为三部分:
  
  class-map:对流量分类
  policy-map:对每类流量分配queue,priority关键字表示使用LLQ。
  server-policy:将policy-map绑定到接口上。
  1、Policy-map配置
  
  class-map match-all VOICE
  
  match ip dscp ef
  
  class-map match-all VIDEO
  
  match ip dscp af41
  
  class-map match-all VOICE-CONTROL
  
  match ip dscp af31
  
  class-map match-any GOLD-DATA
  
  match ip dscp af21
  
  match ip dscp af22
  
  match ip dscp af23
  
  class-map match-any SILVER-DATA
  
  match ip dscp af11
  
  match ip dscp af12
  
  match ip dscp af13
  
  !
  
  policy-map WAN-EDGE
  
  class VOICE
  
  priority percent 17
  
  class VIDEO
  
  priority percent 16 30000
  
  class VOICE-CONTROL
  
  bandwidth percent 2
  
  class GOLD-DATA
  
  bandwidth percent 25
  
  random-detect dscp-based
  
  class SILVER-DATA
  
  bandwidth percent 15
  
  random-detect dscp-based
  
  class class-default
  
  fair-queue
  
  random-detect dscp-based
  
  random-detect dscp-based
  
  random-detect dscp 0 96 128 10
  
  random-detect dscp 2 70 128 10
  
  random-detect dscp 4 58 128 10
  
  random-detect dscp 6 44 128 10
  
  2、PPP配置
  
  interface Multilink 40
  
  bandwidth 4096
  
  ip address 10.200.40.1 255.255.255.252
  
  service-policy output WAN-EDGE
  
  ppp multilink
  
  multilink-group 40
  
  interface Serial1/0
  
  description Link E1-A to BRANCH#40
  
  bandwidth 2048
  
  no ip address
  
  encapsulation ppp
  
  ppp multilink
  
  multilink-group 40
  
  interface Serial1/1
  
  description Link E1-B to BRANCH#40
  
  bandwidth 4096
  
  no ip address
  
  encapsulation ppp
  
  ppp multilink
  
  multilink-group 40
  
  3、FR配置:
  
  interface Serial0/1
  
  description Parent FR Link
  
  no ip address
  
  encapsulation frame-relay
  
  !
  
  interface Serial0/1.50 point-to-point
  
  description FR Link to BRANCH#50
  
  bandwidth 3000
  
  ip address 10.200.50.1 255.255.255.252
  
  frame-relay interface-dlci 211
  
  class REMOTE-BRANCH-3000kbps
  
  map-class frame-relay REMOTE-BRANCH-3000kbps
  
  frame-relay cir 3000000
  
  frame-relay bc 30000
  
  frame-relay be 0
  
  frame-relay mincir 3000000
  
  no frame-relay adaptive-shaping
  
  service-policy output WAN-EDGE
  
  4、ATM配置
  
  interface ATM4/0
  
  bandwidth 3000
  
  no ip address
  
  no atm ilmi-keepalive
  
  !
  
  interface ATM4/0.60 point-to-point
  
  bandwidth 3000
  
  ip address 10.210.60.1 255.255.255.252
  
  pvc BRANCH#60 0/60
  
  vbr-nrt 3000 3000
  
  tx-ring-limit 3
  
  service-policy output WAN-EDGE
  
  5、远程分支办公室配置
  
  ip cef
  
  !
  
  class-map match-all VOICE
  
  match ip dscp ef
  
  class-map match-all VIDEO
  
  match ip dscp af41
  
  class-map match-all VOICE-CONTROL
  
  match ip dscp af31
  
  class-map match-any GOLD-DATA
  
  match ip dscp af21
  
  match ip dscp af22
  
  match ip dscp af23
  
  class-map match-any SILVER-DATA
  
  match ip dscp af11
  
  match ip dscp af12
  
  match ip dscp af13
  
  class-map match-all SAP
  
  match access-group 100
  
  class-map match-all SQLNET
  
  match protocol sqlnet
  
  class-map match-all CITRIX
  
  match protocol citrix
  
  class-map match-any EMAIL
  
  match protocol pop3
  
  match protocol imap
  
  match protocol smtp
  
  class-map match-all TELNET
  
  match protocol telnet
  
  class-map match-all RCMD
  
  match protocol rcmd
  
  class-map match-all FTP
  
  match protocol ftp
  
  class-map match-all BACKUPS
  
  match access-group 101
  
  class-map match-any P2P
  
  match protocol napster
  
  match protocol fasttrack
  
  !
  
  policy-map WAN-EDGE
  
  class VOICE
  
  priority percent 17
  
  class VIDEO
  
  priority percent 16 30000
  
  class VOICE-CONTROL
  
  bandwidth percent 2
  
  class GOLD-DATA
  
  bandwidth percent 25
  
  random-detect dscp-based
  
  class SILVER-DATA
  
  bandwidth percent 15
  
  random-detect dscp-based
  
  class class-default
  
  fair-queue
  
  random-detect dscp-based
  
  random-detect dscp-based
  
  random-detect dscp 0 96 128 10
  
  random-detect dscp 2 70 128 10
  
  random-detect dscp 4 58 128 10
  
  random-detect dscp 6 44 128 10
  
  !
  
  policy-map REMOTE-LAN-EDGE-OUT
  
  class VOICE
  
  set cos 5
  
  class VOICE-CONTROL
  
  set cos 3
  
  class VIDEO
  
  set cos 4
  
  class GOLD-DATA
  
  set cos 2
  
  class SILVER-DATA
  
  set cos 1
  
  class class-default
  
  set cos 0
  
  !
  
  policy-map REMOTE-LAN-EDGE-IN
  
  class SAP
  
  set ip dscp af21
  
  class SQLNET
  
  set ip dscp af22
  
  class CITRIX
  
  set ip dscp af23
  
  class EMAIL
  
  set ip dscp af11
  
  class TELNET
  
  set ip dscp af12
  
  class RCMD
  
  set ip dscp af13
  
  class FTP
  
  set ip dscp 2
  
  class BACKUPS
  
  set ip dscp 4
  
  class P2P
  
  set ip dscp 6
  
  !
  
  !
  
  interface FastEthernet0/0
  
  description CAT3500 REMOTE-BRANCH ACCESS-SWITCH
  
  no ip address
  
  load-interval 30
  
  speed auto
  
  duplex auto
  
  !
  
  interface FastEthernet0/0.50
  
  description NATIVE SUBNET 10.1.50.0 DATA
  
  encapsulation dot1Q 50
  
  ip address 10.1.50.1 255.255.255.0
  
  service-policy output REMOTE-LAN-EDGE
  
  service-policy input REMOTE-LAN-EDGE-IN
  
  !
  
  !
  
  interface FastEthernet0/0.150
  
  description NATIVE SUBNET 10.1.150.0 VOICE
  
  encapsulation dot1Q 150
  
  ip address 10.1.150.1 255.255.255.0
  
  service-policy output REMOTE-LAN-EDGE
  
  
  
  interface Multilink1
  
  bandwidth 4096
  
  ip address 10.200.40.2 255.255.255.252
  
  service-policy output WAN-EDGE
  
  ppp multilink
  
  multilink-group 1
  
  !
  
  interface Serial1/0
  
  bandwidth 2048
  
  no ip address
  
  encapsulation ppp

本文来源:天下网吧 作者:网吧方案

声明
声明:本站所发表的文章、评论及图片仅代表作者本人观点,与本站立场无关。若文章侵犯了您的相关权益,请及时与我们联系,我们会及时处理,感谢您对本站的支持!联系Email:support@txwb.com,系统开号,技术支持,服务联系QQ:1175525021本站所有有注明来源为天下网吧或天下网吧论坛的原创作品,各位转载时请注明来源链接!
天下网吧·网吧天下